httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <wr...@rowe-clan.net>
Subject Quieting warnings?
Date Mon, 28 Nov 2016 19:37:21 GMT
Typical of a long batch of error noise on 2.4 HEAD (with the
http strict merge patch applied) in --enable-maintainer-mode...

In file included from
/home/wrowe/dev/httpd-2.4/modules/mappers/mod_vhost_alias.c:45:0:
/home/wrowe/dev/httpd-2.4/include/http_config.h:427:24: warning:
'aplog_module_index' defined but not used [-Wunused-const-variable=]
     static int * const aplog_module_index = &(foo##_module.module_index)
                        ^
/home/wrowe/dev/httpd-2.4/include/http_config.h:437:5: note: in expansion
of macro 'APLOG_USE_MODULE'
     APLOG_USE_MODULE(foo);                         \
     ^~~~~~~~~~~~~~~~
/home/wrowe/dev/httpd-2.4/modules/mappers/mod_vhost_alias.c:447:1: note: in
expansion of macro 'AP_DECLARE_MODULE'
 AP_DECLARE_MODULE(vhost_alias) =
 ^~~~~~~~~~~~~~~~~

Has anyone investigated far enough for us to pacify gcc?

Mime
View raw message