httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Schleusener" <Jens.Schleuse...@t-online.de>
Subject Re: T&R 2.4.23 tomorrow (Thurs) ??
Date Mon, 27 Jun 2016 11:00:49 GMT
On Fri, 24 Jun 2016, William A Rowe Jr wrote:

> On Thu, Jun 23, 2016 at 10:38 AM, Jens Schleusener <Jens.Schleusener@t-online.de>
wrote:
> 
> ... good news.
> 
> So now nearly superfluous info but just for completeness: Your first patch for modules/proxy/config.m4
> sent at "Thu, 23 Jun 2016 07:32:02 -0500" solved at least the superficial problem and
let the configure
> run end without an error.
> 
> 
> The entire solution is now presented in STATUS, but for reviewers 
> I've rolled up all of the diffs into a single delta that can be applied
> to either 2.4.21 or 2.4.22 release candidates for easier testing;
> 
> https://raw.githubusercontent.com/wrowe/patches/master/proxy-rollup-2.4.21.patch
> 
> This will hopefully address every edge case with the proxy and
> proxy sub-modules logic in ./configure (just be sure to re-run
> ./buildconf after applying this patch!)

Ok, I applied the patch to both release candidates and a

  ./configure --enable-mods-shared=few

ends without errors (using openSUSE Leap 42.1; autoconf-2.69-11.4.noarch; 
libtool-2.4.2-16.6.x86_64).

But a subsequent "make" produces to the expected 21 modules 
additionally the 4 modules

  modules/proxy/balancers/.libs/mod_lbmethod_bybusyness.so
  modules/proxy/balancers/.libs/mod_lbmethod_byrequests.so
  modules/proxy/balancers/.libs/mod_lbmethod_bytraffic.so
  modules/proxy/balancers/.libs/mod_lbmethod_heartbeat.so

As since yesterday httpd-2.4.x seems now accordingly patched I tried that 
branch and it also works with the above configure command and a subsequent 
"make" produces just the expected 21 modules.

So for the original reported error regarding the configure option 
--enable-mods-shared=few the fixes seems ok now.

But some observations (from an outsider):

1) Just a pure ./configure (probably equivalent to using the option 
--enable-mods-shared=most) let produce the "make" (compared to the last 
release 2.4.20) 86 modules instead 85 modules with the additional modules

  modules/core/.libs/mod_watchdog.so
  modules/proxy/.libs/mod_proxy_hcheck.so

and the omitted module

  modules/session/.libs/mod_session_crypto.so

That may be expected.

By the way the option --enable-mods-shared=all produces 103 modules and 
--enable-mods-shared=reallyall 120 ones.

2) But for me surprising the option--enable-mods-shared=none seems to have 
the same configuration effect as the option--enable-mods-shared=most 
(producing 86 modules) respectively the option is ignored and the default 
"most" is used.

Similar for e.g. --enable-mods-shared='headers rewrite dav' (an example 
from the documentation page 
http://httpd.apache.org/docs/2.4/programs/configure.html) seems to produce 
the same behaviour like --enable-mods-shared=most while I would expect 
that only the three specified modules would be buillt.

Odd, also arbitray module names like --enable-mods-shared=nonsense seems 
equivalent to --enable-mods-shared=most.

But that is an error it seems not a regression since 2.4.20 shows the same 
behaviour.

Regards

Jens
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message