httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <wr...@rowe-clan.net>
Subject Re: T&R 2.4.23 tomorrow (Thurs) ??
Date Thu, 23 Jun 2016 12:10:39 GMT
On Jun 23, 2016 6:13 AM, "Jens Schleusener" <Jens.Schleusener@t-online.de>
wrote:
>
> On Wed, 22 Jun 2016, Jim Jagielski wrote:
>
>> Subj sez it all... afaict, there are no showstoppers and
>> no outstanding issues (none seen in STATUS, or noted as
>> such on any Email threads).
>>
>> Sooooo... anyone opposed to a T&R tomorrow in the hopes
>> of getting this out to people by the start of next week??
>
>
> Just for curiosity I copied the soure code via
>
>  svn checkout http://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x
>
> and did for building the "configure" script a
>
>  src/httpd-2.4.x> ./buildconf
>
>  found apr source: srclib/apr
>  rebuilding srclib/apr/configure
>  buildconf: checking installation...
>  buildconf: python version 2.7.9 (ok)
>  buildconf: autoconf version 2.69 (ok)
>  buildconf: libtool version 2.4.2 (ok)
>  buildconf: copying libtool helper files using /usr/bin/libtoolize
>  buildconf: creating include/arch/unix/apr_private.h.in ...
>  buildconf: creating configure ...
>  buildconf: generating 'make' outputs ...
>  buildconf: rebuilding rpm spec file
>  copying build files
>  rebuilding include/ap_config_auto.h.in
>  rebuilding configure
>  rebuilding rpm spec file
>  fixing timestamps for ap_expr sources
>
> and then issued
>
>  src/httpd-2.4.x> ./configure --enable-mods-shared=few
>
>  configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
>  checking for chosen layout... Apache
>  [... many lines deleted ...]
>  checking whether to enable mod_proxy_express... no (few)
>  checking whether to enable mod_proxy_hcheck... checking dependencies
>  configure: WARNING: "mod_proxy is disabled but required for
mod_proxy_hcheck"
>  checking whether to enable mod_proxy_hcheck... configure: error:
>  mod_proxy_hcheck has been requested but can not be built due to
prerequisite failures
>
> So it appears not the identical but a similar failure compared to that
one I reported some days ago ("Small problem in "configure" script with
2.4.21"): Now "mod_watchdog" is replaced by "mod_proxy".
>
> And again: Since the option "--enable-mods-shared=few" doesn't include
any "proxy"-related modules I also don't expect to build the "reverse-proxy
health-check module".
>
> I am not sure if there is still a problem or if my "configure" building
and testing is incorrect.

Reviewing.  For fun, please post the output of ./buildconf
And uname -a

Mime
View raw message