httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: proxy API compat break in 2.4.7
Date Thu, 07 Apr 2016 22:55:11 GMT
On Thu, Apr 7, 2016 at 8:09 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:
> Revision 1560081 (backport of r1533087) introduced "char
> uds_path[PROXY_WORKER_MAX_NAME_SIZE]" in the middle of the
> proxy_worker_shared structure which IMHO broke compatibility between 2.4.6
> and 2.4.7.

Possibly [1] (currently proposed for backport) may cause the same issue.
We should probably fix it (ie. move the new fields to the end of
proxy_worker_shared) to make it backportable...

Regards,
Yann.

[1] http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/proxy/mod_proxy.h?r1=1667707&r2=1725545&diff_format=h

Mime
View raw message