httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: Test framework vs IPv6
Date Mon, 21 Mar 2016 11:16:06 GMT
On Mon, Mar 21, 2016 at 10:00 AM, Plüm, Rüdiger, Vodafone Group
<ruediger.pluem@vodafone.com> wrote:
>
>> From: Stefan Eissing
>> Sent: Montag, 21. März 2016 09:48
>>
>> I encountered this once on a new image where /etc/hosts listed first
>> localhost ::1

Mine is listing 127.0.0.1 first, so it may depend on the network stack
too (I run some pretty young Linux 4.4 kernel..).
I'll try the other way around though, but it can't be a solution anyway.
It worked with sysctl -w net.ipv6.conf.lo.disable_ipv6=0 for me.

>>
>> Like you, I found that there seems to be no quick fix for this and
>> edited /etc/hosts...
>>
>> I think your listen patch should be applied.
>
> +1

OK, I'll (try to) fix the other tests which don't pass with "Listen <port>"...
Namely:
- t/apache/expr.t
- t/modules/access.t
- t/modules/setenvif.t
- t/ssl/varlookup.t

It may be related to REMOTE_ADDR being IPv6 now, will check.

>
> Just one comment on the patch. If you want to keep the old code in as commented
> you should probably put in a comment above that explains the issue with IPv6.
> Otherwise I guess it is somewhat pointless to keep old code commented out.
> We are under version control :-)

Yes, a quick patch, not meant to be committed as is, more to keep the
original code in mind while trying several things :)

Regards,
Yann.

Mime
View raw message