httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <>
Subject Re: HTTPS connections lock-up with 2.4.18
Date Mon, 01 Feb 2016 12:19:06 GMT
On Mon, Feb 1, 2016 at 10:10 AM, Joachim Achtzehnter <> wrote:
> The problem was first discovered with Apache 2.4.18 compiled against
> OpenSSL/1.0.1m. The running system, which is an i686 Linux system, used the
> same versions.
> We then installed our old from Apache 2.4.12, everything else
> unchanged, and this worked. This was enough of a hint to debug the 2.4.18
> version of the module. Before doing this, we downloaded the latest
> apr/apr-util, and OpenSSL packages, and rebuilt everything. OpenSSL is now
> at 1.0.2f. All of this was installed on the running system, and it behaved
> the same way, with some files causing the client to hang forever.

Thanks for the details.

> Applying the patch I included in the previous message gets it working for
> us.

This restores the previous (pre 2.4.18) behaviour of flushing output
on every read, which I'd prefer to avoid, if possible.

Could you provide some network capture (tcpdump, wireshark...) when
the lock-up occurs?
Is EnableMMap somehow always involded here (you mention it in the
original message)?
That would help to build a reproducer...

Maybe the attached patch could be "enough" to fix the issue?
This patch also includes some minimal logging (level NOTICE) to help
diagnose in case of lock-up, still.
It may be necessary to apply patch [1] before (conflict with current
2.4.x, which the attached patch is based on).



View raw message