httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: httpd-2.4 --enable-load-all-modules side-effect
Date Fri, 12 Feb 2016 17:47:40 GMT
Am 08.02.2016 um 20:47 schrieb Rainer Jung:
> Hi Bill,
>
> Am 08.02.2016 um 19:11 schrieb William A Rowe Jr:
>> ./configure [...]
>> "--with-mods-shared=all" \
>> "--enable-mods-shared=all" \
>> "--enable-mpms-shared=all" \
>> "--enable-load-all-modules" \
>> "--with-mpm=worker" \
>>
>> While this should be great for testing a variety of modules and
>> is very helpful for building it all, the resulting httpd.conf isn't quite
>> helpful...
>>
>> LoadModule mpm_event_module modules/mod_mpm_event.so
>> LoadModule mpm_prefork_module modules/mod_mpm_prefork.so
>> LoadModule mpm_worker_module modules/mod_mpm_worker.so
>>
>> We obviously cannot load multiple mpm modules :)
>>
>> Can someone more familiar with the --enable-load-all-modules
>> or --enable-mpms-shared/--with-mpm mechanics take a look at
>> fixing this behavior before we roll on to a 2.4.19 release?
>>
>> If not, I will try to take a look, but the plate is pretty full with
>> other
>> half-completed projects here.
>
> Could you apply r1729235 to your checkout and see whether it works for you?
>
> The indentation of the shell snippets in the Makefile is broken, but
> that's an older annoyance we can independently.

I have changed the impl a bit in 1730079. Maybe you can try some time.

Regards,

Rainer

Mime
View raw message