httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [VOTE] Release Apache httpd 2.4.18 as GA
Date Fri, 11 Dec 2015 21:57:46 GMT
On Fri, Dec 11, 2015 at 10:39 PM, Yann Ylavic <ylavic.dev@gmail.com> wrote:
> On Fri, Dec 11, 2015 at 9:21 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:
>>
>>   - three compiler warning (2 regressions, one old)
> []
>>       modules/ssl/ssl_engine_kernel.c:414:22: warning: variable 'hssc' set
>> but not used [-Wunused-but-set-variable]
>
> This one is harmless ('hssc' redeclared and used below in inner scope).
> But I checked twice since handshakeserver (there) is not checked
> against NULL like at the initialization.
> Fortunately the !ssl path above handles the case, so this is simply a
> double initialization (to the same value), likely optimized away
> finally...
>
> -Wunused-but-set-variable does its job, though.

The original commit in trunk (r1709995) contained:
@@ -529,7 +672,6 @@ int ssl_hook_Access(request_rec *r)
      */
     if ((dc->nVerifyClient != SSL_CVERIFY_UNSET) ||
         (sc->server->auth.verify_mode != SSL_CVERIFY_UNSET)) {
-        SSLSrvConfigRec *hssc = mySrvConfig(handshakeserver);

         /* remember old state */
         verify_old = SSL_get_verify_mode(ssl);
--

But somehow the merge in 2.4.x (r1715255, from
2.4.17-protocols-changes branch?) does not.

Looks like a merge issue :/
Comparing files now...

Mime
View raw message