httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [VOTE] Release Apache httpd 2.4.18 as GA
Date Fri, 11 Dec 2015 21:39:01 GMT
On Fri, Dec 11, 2015 at 9:21 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:
>
>   - three compiler warning (2 regressions, one old)
[]
>       modules/ssl/ssl_engine_kernel.c:414:22: warning: variable 'hssc' set
> but not used [-Wunused-but-set-variable]

This one is harmless ('hssc' redeclared and used below in inner scope).
But I checked twice since handshakeserver (there) is not checked
against NULL like at the initialization.
Fortunately the !ssl path above handles the case, so this is simply a
double initialization (to the same value), likely optimized away
finally...

-Wunused-but-set-variable does its job, though.

Mime
View raw message