httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <>
Subject Re: strncasecmp
Date Tue, 24 Nov 2015 16:53:28 GMT
On Tue, Nov 24, 2015 at 10:07 AM, Mikhail T. <>

> On 24.11.2015 10:08, William A Rowe Jr wrote:
> As long as this function is promoted for fast ASCII-specific token
> recognition and has no other unexpected equalities, it serves a useful
> purpose.
> Because of this, I'd suggest renaming it to something, that emphasizes it
> being ASCII-only.

Strictly speaking, you are referring to US-ASCII, while the actual function
the EBCDIC build follows LC_CTYPE/LC_COLLATE C or POSIX (equivalent names
for the same thing) and is honoring LC_COLLATE of the US-ASCII ordering.

apr_strcasecmp_lcposix or apr_strcasecmp_lcc might be a usable name.  Other
suggestions?  I was leaning toward apr_strcasecmp_token since that is a
well recognized RFC term and usually refers to the ASCII set.  For HTTPbis,
is defined at

View raw message