httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Wang <>
Subject Re: [users@httpd] Chunked transfer delay with httpd 2.4 on Windows.
Date Fri, 23 Oct 2015 19:17:56 GMT

On 10/22/2015 04:50 PM, Yann Ylavic wrote:
> On Thu, Oct 22, 2015 at 3:42 PM, Andy Wang <> wrote:
>> Tested with the patch and looks good.
> Not that much actually, the patch fails to consume the CRLFs, and
> hence can end up in an infinite loop.
> So I'm attaching a new one here (committed in trunk with a larger
> scope, this version is for 2.4.x and limited to your use case).
> Could you give it a (new) try please (I have already done some testing
> but it's probably worth passing your tests, before I can propose its
> backport to 2.4.x)?
> While the previous patch could not handle more than a single
> (trailing) [CR]LF, this new one should (up to ten, which is the new
> limit for tolerated blank lines in between requests).

The new one works as well.  My VMs that I use for my actual test cases 
are all in a logistics nightmare right now, so I can't do anything more 
thorough than the specific point test, but hopefully when I build the 
next httpd that contains this they'll be back up and I can put things 
through a more thorough cycle.

I'm pretty much only equipped to reproduce the specific problem right now.

That said, this whole, why does it only happen on Windows and why can't 
I simulate a request using another client has been bugging me, so I 
decided to go back to pre-patch and enable dumpio and try to compare the 

guess what
I cannot get the problem to occur with dumpio enabled now.  As soon as 
it's enabled, the requests respond immediately.

Disable dumpio, 5000ms.

I give up.  The plugin developer fixed their plugin, you made apache 
more accepting (thank you very much again), and I'm going to just 
pretend this whole issue never happened :)


View raw message