httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [VOTE] Release Apache httpd 2.4.17 as GA
Date Mon, 12 Oct 2015 15:44:15 GMT
Am 09.10.2015 um 19:40 schrieb Jim Jagielski:
> The pre-release test tarballs for Apache httpd 2.4.17 can be found
> at the usual place:
>
> 	http://httpd.apache.org/dev/dist/
>
> I'm calling a VOTE on releasing these as Apache httpd 2.4.17 GA.
>
> [X] +1: Good to go
> [ ] +0: meh
> [ ] -1: Danger Will Robinson. And why.
>
> Vote will last the normal 72 hrs.

+1 to release and thank a bunch for RMing.
Hooray to HTTP/2.

In short: No regressions found.

Detailed report:

- Sigs and hashes OK
- contents of tarballs identical
- contents of tag and tarballs identical
   except for expected deltas
   (we could cleanup some m4 files in apr-util/xml/expat/conftools
    at the end of buildconf, no regression)

Built on

- Solaris 8+10 Sparc as 32 Bit Binaries
- SLES 10+11 (64 Bits)
- RHEL 6 (64 Bits)

For all platforms built

- with default (shared), shared and static modules
- with module sets none, few, most, all, reallyall and default
   (always mod_privileges disabled)
- using --enable-load-all-modules
- against "included" APR/APU from deps tarball,
   plus external APR/APU 1.5.2/1.5.4

- using external libraries
   - expat 2.1.0
   - pcre 8.37
   - openssl 1.0.2d
   - lua 5.2.4
   - distcache 1.5.1
   - libxml2 2.9.2
   - libnghttp2 1.3.4

- Tool chain:
     - platform gcc except for Solaris
       (gcc 4.1.2 for Solaris 8 and 4.9.2 for Solaris 10)
     - CFLAGS: -O2 -g -Wall -fno-strict-aliasing
               (and -mpcu=v9 on Solaris)

All builds succeeded
   - one compiler warning (no regression)
ssl/ssl_util_stapling.c:657: warning: 'ok' may be used uninitialized in 
this function

Tested for

- Solaris 8+10 (32), SLES 10+11 (64), RHEL 6 (64)
- MPMs prefork, worker, event
   (except event on Solaris8, unsupported)
- default, shared and static modules
- log levels info, debug and trace8
- module set reallyall (122 modules plus MPMs)
- Solaris 8 and SLES 10 still ongoing but so far OK

The following test failures were seen:

a Test 4 or 5 in t/modules/dav.t:
   Happens for 38 out of 319 runs (7 on SLES 10, 16 on SLES 11,
   13 on RHEL6, 2 on Solaris 10).
   Creation, modified and now times not in the correct order.
   This seems to be a system issue, all tests done on NFS,
   many tested on virtualized guests.
   Not a regression.

b Various tests in t/apache/expr_string.t: (6, 11, 14, 17, 20 ,23)
   Happens for 41 out of 319 runs (31 on SLES 10, 1 on SLES 11,
   9 on RHEL6).
   The failure is always on line 68, where the error_log contents
   are checked.
   Not a regression.

c Test 59 of t/modules/include.t only and always on
   Solaris.
   This is due to a bug in the test, which uses strftime()
   with a "%s" pattern that is not supported on Solaris.
   Until recently the server and the test client both returned
   verbatim "%s" and the test succeeded. After updating some
   Perl modules for the http2 tests, the perl client even
   on Solaris now supports "%s" in strftime and the test starts
   to fail. It seems we have to fix the test.

d Failure of t/modules/session.t on SlES 10.
   Warning: Use of "shift" without parentheses is ambiguous at line 39.
   Perl version is 5.8.8. The script uses a somewhat advances
   $x = shift // "NOTFOUND";
   construct, which seems to be ambiguous for old Perl (I had
   to look in the fine perl docs for the // operator).
   We could probably use a less elegant but more compatible
   construct instead.

e Failure of two tests in t/modules/http2.t.
   The tests do not run in a consistent order, so the test numbers don't
   help, but it always seems to be the "misdirected" test under SSL
   returning 404 instead of 421. Analysis by Yann indicates, that
   the test might be broken and needs some refinement to actually
   trigger a 421.

Regards,

Rainer

Mime
View raw message