httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steffen" <i...@apachelounge.com>
Subject 2.4.17-protocols-http2 :: Restarting
Date Mon, 21 Sep 2015 07:27:32 GMT
Running live now for almost two days, see https://www.apachelounge.com/viewtopic.php?p=31674

Was running fine, expect the log is filled with mod_h2 warnings (see below)
Suddenly after a few hours, it was starting all over and over, 105 times.
And running fine for a few hours without restarting. 

Looks like a (bad) client is causing it.

Now I disabled mod_h2, to see if that is fine.

[mpm_winnt:notice] [pid 1644:tid 16] AH00428: Parent: child process 2036 exited with status
3221225477 -- Restarting.

Windows says: Faulting module name: mod_h2.so, version: 2.4.17.

Log is filled (over 2000) with:

[h2:warn] [pid 2036:tid 4008] (OS 10060)A connection attempt failed because the connected
party did not properly respond after a period of time, or established connection failed because
connected host has failed to respond.  : [client 84.105.35.206:58278] AH02950: h2_session(124):
error reading, terminating

Few other errors/warning:

[h2:warn] [pid 2036:tid 4020] (70015)Could not find specified socket in poll list.: [client
90.21.243.213:57391] AH02953: h2_mplx(126): stream for response 49

[h2:error] [pid 3300:tid 2832] (OS 10053)An established connection was aborted by the software
in your host machine.  : [client 202.183.129.112:47902] AH02925: h2_stream(116-35): failed
send_data_cb

[h2:error] [pid 3300:tid 2856] (OS 10054)An existing connection was forcibly closed by the
remote host.  : [client 177.41.118.92:52990] AH02925: h2_stream(123-29): failed send_data_cb

Logs (level notice) attached.

Steffen
Mime
View raw message