httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: The show goes on - 2.4.16
Date Thu, 16 Jul 2015 14:41:05 GMT
My comment is that with 2.4.12 the same configure did not do this. This is
new behavior.

I was testing with 2.4.12 all day yesterday, using the same build scripts
today with 2.4.16 came up differently.

So now, after the build I have this difference in httpd.conf

root@x065:[/data/prj/apache/httpd]diff -u */x/etc/httpd/httpd.conf
--- httpd-2.4.12/x/etc/httpd/httpd.conf 2015-07-16 09:48:20 +0000
+++ httpd-2.4.16/x/etc/httpd/httpd.conf 2015-07-16 12:31:25 +0000
@@ -143,6 +143,7 @@
 LoadModule lbmethod_bytraffic_module libexec/mod_lbmethod_bytraffic.so
 LoadModule lbmethod_bybusyness_module libexec/mod_lbmethod_bybusyness.so
 LoadModule lbmethod_heartbeat_module libexec/mod_lbmethod_heartbeat.so
+LoadModule mpm_prefork_module libexec/mod_mpm_prefork.so
 LoadModule mpm_worker_module libexec/mod_mpm_worker.so
 LoadModule unixd_module libexec/mod_unixd.so
 LoadModule heartbeat_module libexec/mod_heartbeat.so


On Thu, Jul 16, 2015 at 4:03 PM, William A Rowe Jr <wrowe@rowe-clan.net>
wrote:

> On Jul 16, 2015 8:04 AM, "Michael Felt" <mamfelt@gmail.com> wrote:
> >
> > First little thing I ran into - that I did not have with 2.4.12 is this:
> >
> > root@x065:[/data/prj/apache/httpd/test]/opt/httpd/sbin/apachectl start
> > AH00534: httpd: Configuration error: More than one MPM loaded.
>
> > root@x065:[/data/prj/apache/httpd/test]grep -i mpm /etc/httpd/httpd.conf
> > LoadModule mpm_prefork_module libexec/mod_mpm_prefork.so
> > LoadModule mpm_worker_module libexec/mod_mpm_worker.so
> > # Server-pool management (MPM specific)
> > #Include /etc/httpd/extra/httpd-mpm.conf
> >
> > p.s. I had done configure with:
> >
> >   $ ./configure --enable-layout=AIX --with-apr=/opt/bin/apr-1-config
> --with-apr-util=/opt/bin/apu-1-config --enable-mpms-shared=all
> --enable-mods-shared=all --disable-lua --enable-load-all-modules
> --enable-maintainer-mode --with-ssl
>
> Looks correct...
>
> --enable-mpms-shared=all
> Worked as instructed...
>
> --enable-load-all-modules
> Did just as you asked.
>
> Not sure offhand if we can hack some mpm-specific module exception to the
> later.
>

Mime
View raw message