httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Wang <aw...@ptc.com>
Subject Re: building httpd 2.2 on windows automation question.
Date Wed, 15 Jul 2015 19:16:24 GMT
Yup, 2.2.31 built fine, and surprisingly it had the ssl deps change too.
I put the nmake into a retry loop :)

And now it's all automated.

Yay.

Thanks for the help,
Andy


On 07/15/2015 10:22 AM, Andy Wang wrote:
>
>
> On 07/14/2015 09:37 PM, Gregg Smith wrote:
>> On 7/14/2015 12:09 PM, Andy Wang wrote:
>>>         link.exe -lib @C:\Users\runtime\AppData\Local\Temp\nm9E02.tmp
>>>         "c:\Program Files (x86)\Microsoft Visual Studio
>>> 10.0\VC\BIN\nmake.exe" -
>>> nologo -f libaprutil.mak      CFG="libaprutil - Win32 Release" RECURSE=0
>>>         if not exist ".\Release/" mkdir ".\Release"
>>>         tempfile.bat
>>> libaprutil.mak(1494) : fatal error U1054: cannot create inline file
>>> 'tempfile.ba
>>> t'
>>> Stop.
>>
>> I've run into this on VC11/Win7x64 more than once. I think I just
>> restarted the build again and it has always gone through. Microsoft says
>> a tempfile.bat already exists with a read-only attribute so it evidently
>> has started creating the file before removing the prior one.
>>
> .. snipped ..
>>
>> Give it another try with 2.2.31 when it arrives, hopefully tomorrow.
>>
>>
>
> Gave it a try with the patched 2.2.31, and you're right, continuing on
> gets around the error.  It does occur about half a dozen times though.
> I'll have to script that in if this works.
>
> The openssl problem bit me though.  And it looks like that change you
> mentioned will do it too.  Haven't patched it yet.
>
> Thanks for pointing this out.
>
> Andy

Mime
View raw message