httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Browder <tom.brow...@gmail.com>
Subject Re: httpd and OpenSSL 1.0.2
Date Mon, 01 Jun 2015 15:22:01 GMT
On Wed, May 27, 2015 at 11:33 AM, Mario Brandt <jblond@gmail.com> wrote:
> Hi Tom,
>
> I tried on Debian 7 and 8 both x64
>
> To see your configure options would help a lot.

Okay, here's what I had to do to my Linux Deb 7, 64-bit system:

1.  Remove any deb packages of httpd, apr, apr-util, openssl.

2.  Source packages used (in order of installation):

  openssl-1.0.2a.tar.gz
  apr-1.5.1.tar.bz2
  apr-util-1.5.4.tar.bz2
  pcre2-10.00.tar.bz2
  httpd-2.4.12.tar.bz2

3.  Build and install:

$ sudo aptitude install zlib1g-dev

openssl
-----------

export SSLDIR=/opt/openssl
./config \
    no-ec2m                         \
    no-rc5                          \
    no-idea                         \
    threads                         \
    zlib-dynamic                    \
    shared                          \
    --prefix=${SSLDIR}              \
    --openssldir=${SSLDIR}          \
    enable-ec_nistp_64_gcc_128      \
  make depend
  make
  make test
  sudo make install

apr
----

  ./configure --with-crypto
  make
  make check
  sudo make install

apr-util
----------
  ./configure --with-apr=/usr/local/apr
  make
  make check
  sudo make install

pcre
------
  ./configure
  make
  make check
  sudo make install

httpd
-------
\# we build all modules for now (all shared except mod_ssl)
# Note that 'session_module' needs to be activated (loaded).
export LDFLAGS="-Wl,-rpath,${SSLDIR}/lib"
$SRCDIR/configure                          \
    --prefix=/usr/local/apache2            \
    --with-included-apr                    \
\
    --enable-ssl                           \
    --enable-ssl-staticlib-deps            \
    --enable-mods-static=ssl               \
    --with-ssl=${SSLDIR}                   \
\
    --enable-mods-shared=reallyall         \
    --with-perl                            \
    --with-python                          \
    --enable-layout=Apache                 \
    --with-pcre=/usr/local/bin/pcre-config \
    --without-ldap                         \
    --enable-session-crypto                \
    --with-crypto                          \
    --with-openssl=${SSLDIR}

make
sudo make install

Notes:

1. I used both local install of apr/apr-util AND source inside httpd.

2. Note --with-crypto option for apr in local build

3. Note I have not modified my LD_LIBRARY_PATH for any of the above programs.

It all works for me.

Hope that helps.

Best regards,

-Tom

Mime
View raw message