httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <wr...@rowe-clan.net>
Subject Re: httpd 2.4 and windows "hangs" and AcceptFilter solution
Date Thu, 11 Jun 2015 02:46:03 GMT
On Wed, Jun 10, 2015 at 4:12 PM, Andy Wang <awang@ptc.com> wrote:

> I can reproduce the first case with the installer, pretty much ondemand
> using our installer stuff.  I've tried reproducing it by ripping out the
> actions that do the Runtime.exec() to call httpd.exe into a separate
> standalone program, and the problem doesn't occur there.  Go figure. But
> when this occurs httpd.exe is unresponsive to localhost AND remote traffic
> immediately.  I think I can get one or maybe 2 requests in and out before
> it additional connections simply hang until a network timeout.  Wireshark
> shows the request is ACKed but that's it.
>
> My initial thought was that something cause the process to be blocked, but
> from what I can tell from Process Explorer/Process Monitor the threads look
> correct and are simply waiting for a request.
>

This sounds like a permissions problem.


> The internet explorer 11 case, I've not seen myself, just from reports of
> other developers I've worked with. It occurs from automated tests, and
> these are mostly remote clients running IE11.


It is possible that the 'data' mode (that ships the first packet(s) into
buffers upon receiving data) is somehow incompatible with a broken IE11
handshake.

Mime
View raw message