httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaspar Brand <httpd-dev.2...@velox.ch>
Subject Re: mod_ssl static linking, the eternal topic...
Date Sun, 28 Jun 2015 15:20:48 GMT
On 23.06.2015 13:40, Stefan Eissing wrote:
> Sorry for missing that: it is still dynamically linked.
> 
>> Am 23.06.2015 um 13:39 schrieb Rainer Jung <rainer.jung@kippdata.de>:
>>
>> Am 23.06.2015 um 11:34 schrieb Stefan Eissing:
>>> Sorry to bother the list, but I am banging my head against the wall trying to
build mod_ssl linked statically with openssl on Ubuntu.
>>>
>>> Is there something obvious that I miss in my
>>>
>>>     configure --enable-ssl=shared --with-ssl=$(BLD_PREFIX) --enable-ssl-staticlib-deps
>>>
>>> ? It works under OS X, but not on Ubuntu 10.04 LTS. $(BLD_PREFIX)/lib shows
>>> -rw-r--r-- 1 sei sei 4498826 Jun 22 18:40 libcrypto.a
>>> lrwxrwxrwx 1 sei sei      18 Jun 22 18:40 libcrypto.so -> libcrypto.so.1.0.0
>>> -r-xr-xr-x 1 sei sei 2682743 Jun 22 18:40 libcrypto.so.1.0.0
>>> ...
>>> -rw-r--r-- 1 sei sei  829936 Jun 22 18:40 libssl.a
>>> lrwxrwxrwx 1 sei sei      15 Jun 22 18:40 libssl.so -> libssl.so.1.0.0
>>> -r-xr-xr-x 1 sei sei  549375 Jun 22 18:40 libssl.so.1.0.0
>>
>> What does "not work" mean? Any errors (which) or is mod_ssl still linked against
the shared libs?

I think you might have been mislead by the naming of the
"--enable-ssl-staticlib-deps" option: it does not have the effect of
forcing mod_ssl.so to be linked statically - it only adds those those
libraries which are "suitable for static linking" (see the documentation
on "--static" in pkg-config(1)).

The essential point is that the $(BLD_PREFIX)/lib directory must not
include any shared libraries (see also
https://mail-archives.apache.org/mod_mbox/httpd-dev/201504.mbox/%3C554072B0.40708%40velox.ch%3E).
As long as libtool finds shared libraries in this directory, it will
prefer them over the static ones.

Kaspar

Mime
View raw message