httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <>
Subject Re: [VOTE] Release Apache httpd 2.4.14 as GA
Date Fri, 12 Jun 2015 17:25:48 GMT
Am 12.06.2015 um 19:12 schrieb William A Rowe Jr:
> Revision 1678233 - (view) (download) (annotate) - [select for diffs]
> Modified Thu May 7 16:26:43 2015 UTC (5 weeks, 1 day ago) by jim
> File length: 57106 byte(s)
> Diff to previous 1674655 (colored)
> Merge r1676085 from trunk:
> consistently output SSLCertificateChainFile deprecation warnings
> Submitted by: kbrand
> Reviewed/backported by: jim
> sent the warnings to the console/main server error log, rather than a
> specific server error log file.  Because this is during config parsing,
> it that may have previously been a bit bucket.  So this could be
> perceived as a regression although the logic and log file activity was
> there for some time.

Indeed there was a discussion thread for r1562500 in 2014 during which 
Falco Schwarz reported, that he did *not* get the log message a anywhere 
(neither console, not log files) when he had the directive only in 
VirtualHosts. After the 2.4.13 change it seems to be new, that you get 
the message massively on console, if you have the directive in frequent 
use inside VHosts. That might well be perceived as a regression.

The 2.4.13 change replaced cmd->server in ap_log_error by NULL. The log 
level "APLOG_WARNING|APLOG_STARTUP" was not changed.


View raw message