httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaspar Brand <>
Subject Re: svn commit: r1677149 - in /httpd/httpd/trunk/modules/ssl: ssl_util_ssl.c ssl_util_ssl.h
Date Sat, 02 May 2015 09:10:50 GMT
On 01.05.2015 16:29, wrote:
> Author: stsp
> Date: Fri May  1 14:28:59 2015
> New Revision: 1677149
> URL:
> Log:
> mod_ssl namespacing: Make SSL_ASN1_STRING_to_utf8 a static function inside
> ssl_util_ssl.c (no callers outside this file). The new static function name
> chosen is convert_asn1_to_utf8, based on the assumption that neither SSL_
> nor ASN1_ are safe prefixes to use without potential future overlap.

Thanks for pushing ahead with the namespace cleanup, Stefan. I'm fine
with making the function static, but would suggest to rename it to
"asn1_string_to_utf8" instead - first, because it's really limited to
ASN.1 strings (doesn't deal with arbitrary ASN.1 data), and second,
because the "_to_" already implies a conversion (plus it matches the
naming of the other comparable functions in ssl_util_ssl.c).


View raw message