httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: namespacing in mod_ssl
Date Mon, 20 Apr 2015 07:29:24 GMT
On Thu, Apr 16, 2015 at 06:42:04AM +0200, Kaspar Brand wrote:
> On 15.04.2015 18:36, Stefan Sperling wrote:
> > However, the actual issue here is that mod_ssl is squatting the SSL_ namespace.
> > Historically this may have made sense (it seems mod_ssl and OpenSSL have
> > shared history/authors). Bill Rowe suggested to try moving mod_ssl's
> > functions into the ap_ namespace to avoid such clashes in the future.
> 
> Agreed that mod_ssl should avoid stepping into the SSL_* yard. As
> pointed out by Jeff, ap_* is fairly foreign in the mod_ssl case, though,
> and my preference is for s/SSL_/ssl_/ for functions and
> s/SSL_/MODSSL_/ for constants (in the latter case, there's actually
> quite some more stuff lurking - SSL_OPT_*, SSL_PROTOCOL_* etc.).

It would be safer to go with a "modssl_" prefix for functions too, I've 
sometimes tried to use that for new things though probably not 
consistently.  OpenSSL's libssl.so does export symbols using the "ssl_" 
prefix, though they are probably all internal things which shouldn't be 
global.

Regards, Joe

Mime
View raw message