httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: apr_skiplist dependency
Date Fri, 13 Mar 2015 11:27:03 GMT
On Fri, Mar 13, 2015 at 12:00 PM, Jim Jagielski <jim@jagunet.com> wrote:
> That is a nice hack... How about if instead of that, we
> simply pull into httpd skiplist, and then when APR's version
> achieves parity, we use that.

Is it still needed?

Once/if we require an upper APR version (but even now with an
APR_VERSION_AT_LEAST(1,6,0) check), we can simply
apr_skiplist_insert_compare(..., indexing_add_comp) =>
apr_skiplist_add(...).

But for now, I'd prefer to keep common code in APR (and hence avoid
maintaining both), since we can still use APR-1.5 without any issue
(including performances!).
If nice improvements or bugs appear in APR skiplist ("incompatible"
with APR-1.5 or httpd releasing cycle), then we could do the pull.

> If that sounds OK, I'll do it on Monday.

I'm not opposed to that either, just -0 now (for skiplist, not talking
about other possible httpd "integrations")...

Mime
View raw message