httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: APR_INT32_MAX used by mod_delate-2.2.29
Date Thu, 06 Nov 2014 13:26:02 GMT
On Sat, Nov 1, 2014 at 6:03 PM, Yann Ylavic <ylavic.dev@gmail.com> wrote:

> mod_deflate in httpd-2.2.29 is using APR_INT32_MAX which is only
> available since APR-1.3.
>
> However httpd-2.x seems to require APR-1.2 only
> (http://httpd.apache.org/docs/2.2/install.html#requirements).
>
> Should we apply something like :
>
> Index: modules/filters/mod_deflate.c
> ===================================================================
> --- modules/filters/mod_deflate.c    (revision 1635743)
> +++ modules/filters/mod_deflate.c    (working copy)
> @@ -47,6 +47,10 @@
>  #define APR_WANT_STRFUNC
>  #include "apr_want.h"
>
> +#ifndef APR_INT32_MAX
> +#define APR_INT32_MAX 0x7fffffff
> +#endif
> +
>  #include "zlib.h"
>
>  static const char deflateFilterName[] = "DEFLATE";
> ?
>
> Regards,
> Yann.
>

+1 here

(babbling about generic concerns with using a level of APR that we haven't
used in years has been removed)

-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message