httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kalu┼ża <jkal...@redhat.com>
Subject Re: Systemd support in 2.4
Date Mon, 15 Sep 2014 06:00:11 GMT
On 09/14/2014 01:21 PM, Martynas Bendorius wrote:
> Hello,
>
> Is there any special reason why mod_systemd and mod_journald (available
> in trunk) are not backported to 2.4 yet?

Hi,

I think mod_systemd could be proposed for 2.4 branch (maybe even with 
the changes adding socket activation), but for mod_journald, we would 
have to backport "modular logging", which breaks the API/ABI and 
therefore I'm afraid that won't happen in 2.4 branch :(.

Jan Kaluza

> As we have a lot of distributions already using systemd by default
> (CentOS/RHEL 7, Fedora, Arch Linux, CoreOS, openSUSE), and more of them
> are going to use systemd by default (Debian 8 (Jessie), Ubuntu), it
> requires manual patching of apache for the support of systemd/journald.
>
> Thank you!
>


Mime
View raw message