httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: svn commit: r1612921 - in /httpd/httpd/trunk: configure.in server/util_pcre.c
Date Thu, 24 Jul 2014 07:54:06 GMT
Am 24.07.2014 um 02:39 schrieb Takashi Sato:
>> --- httpd/httpd/trunk/configure.in (original)
>> +++ httpd/httpd/trunk/configure.in Wed Jul 23 19:01:45 2014
>> @@ -236,7 +236,9 @@ if test "$PCRE_CONFIG" != "false"; then
>>     fi
>>     case `$PCRE_CONFIG --version` in
>>     [[1-5].*])
>> -    AC_MSG_ERROR([Need at least pcre version 6.0])
>> +    AC_MSG_ERROR([Need at least pcre version 6.7])
>> +  [6.[0-6]*])
>> +    AC_MSG_ERROR([Need at least pcre version 6.7])
>>       ;;
>>     esac
>>     AC_MSG_NOTICE([Using external PCRE library from $PCRE_CONFIG])
>
> This causes an error:
>
> checking for pcre-config... /usr/bin/pcre-config
> ./configure: line 6115: syntax error near unexpected token `)'
> ./configure: line 6115: `  6.[0-6]*)'
>
> I think following fix is needed.
>
> Index: configure.in
> ===================================================================
> --- configure.in        (revision 1612973)
> +++ configure.in        (working copy)
> @@ -237,6 +237,7 @@
>     case `$PCRE_CONFIG --version` in
>     [[1-5].*])
>       AC_MSG_ERROR([Need at least pcre version 6.7])
> +    ;;
>     [6.[0-6]*])
>       AC_MSG_ERROR([Need at least pcre version 6.7])
>       ;;
>

Oups, yes, sorry, applied in r1613029 (and also tested this time).

Regards,

Rainer

Mime
View raw message