httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: Resolving apr dependencies while generating httpd rpm build compiled from source
Date Mon, 03 Mar 2014 08:58:36 GMT
On 3 Mar 2014, at 08:05, Venkatesh Prabu Narayanan <venkateshprabu06@gmail.com> wrote:

> Further to my previous mail, I have generated apr rpm build and successfully installed
after installing the dependency packages (autoconf, libtool, doxygen).
> 
> After this I tried installing apr-util 1.5.3 version and it has the following dependencies,
> 
> [root@localhost apr-util]# rpmbuild -ba apr-util.spec
> error: Failed build dependencies:
>         libuuid-devel is needed by apr-util-1.5.3-1.i386
>         postgresql-devel is needed by apr-util-1.5.3-1.i386
>         mysql-devel is needed by apr-util-1.5.3-1.i386
>         sqlite-devel >= 3.0.0 is needed by apr-util-1.5.3-1.i386
>         freetds-devel is needed by apr-util-1.5.3-1.i386
>         unixODBC-devel is needed by apr-util-1.5.3-1.i386
>         nss-devel is needed by apr-util-1.5.3-1.i386
> 
> 
> I just commented out all the above dependencies and this time I am getting segmentation
fault while doing rpmbuild as below,

Don't comment out the dependencies, install them with "yum install".

Regards,
Graham
--


Mime
View raw message