httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: 2.2.27 tagged today
Date Thu, 13 Mar 2014 19:37:07 GMT
First, big props and thank yous to RĂ¼diger for a flurry of svn tree
and backport maintenance, I owe you >1 beers/coffees :)

Trouble.  From www.apache.org/dist/apr/ as near as I can tell the APR
project discontinued the 1.4.x branch by removing it from their package
distributions.  It seems inconceivable that we would ship something that
upstream has withdrawn from distribution.

As much as compatibility is important, httpd 2.2 will run just fine
under APR 1.3, 1.4 or 1.5.  I don't see an alternative to bumping our
included APR up to 1.5.0 (and APR-util to 1.5.3, but that could have
gone without saying).  I'm adjusting the Announcement draft language
to reflect that, right now.

Unless I hear loud objection in the next 55 minutes or so, the packages
will be up next hour with that minor revision bump to APR.

Bill

Mime
View raw message