httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: modules calling ap_lingering_close()!!!
Date Thu, 20 Feb 2014 17:24:23 GMT
On Thu, Feb 20, 2014 at 10:23 AM, Joe Orton <jorton@redhat.com> wrote:

> On Thu, Feb 20, 2014 at 07:52:34AM -0500, Jeff Trawick wrote:
> > WSGI 3.4 daemon mode crashing with httpd 2.4.x...
> >
> > Program received signal SIGSEGV, Segmentation fault.
> > [Switching to Thread 0xaef17b70 (LWP 32761)]
> > 0x08078a32 in update_child_status_internal ()
> > (gdb) where
> > #0  0x08078a32 in update_child_status_internal ()
> > #1  0x0809952d in ap_start_lingering_close ()
> > #2  0x080995a9 in ap_lingering_close ()
>
> Fixed in:
>
>
> http://code.google.com/p/modwsgi/source/detail?path=/mod_wsgi.c&name=mod_wsgi-3.X&r=bdbeacb88f348909845445e9d52eb7be401abaf1
>
> mod_wsgi does some surprising things with httpd interfaces which should
> probably be internal-only, or at least better documented API!
>
> Regards, Joe
>

BTW, do you know if there's a known collection of patches for 2.4 support
or for other critical fixes?

-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message