httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: ApacheCon talk topic suggestions
Date Sat, 25 Jan 2014 12:52:16 GMT
On Fri, Jan 24, 2014 at 9:12 PM, Kean Johnston <kean.johnston@gmail.com>wrote:

> On 1/21/2014 7:46 PM, Rich Bowen wrote:
>
>> * FCGI
>>
> If anyone plans of giving a talk about FCGI please let me know. I can't
> attend but have some input (and a new module I am almost done with) that
> may be useful.


Suggestion: Write a blog post with your thoughts and a description of your
in-progress module, then point to it here.

It is very possible that multiple people have submitted a proposal for a
FastCGI talk.  (I have.)  There is a lot to cover potentially, and an
attempt to coordinate coverage might rightfully result in two approved
talks (subject to available slots and other proposals).  But people are
busy and talk submission is mostly a shot in the dark.

I've thought about AC2014 FastCGI coverage requirements in terms of deltas
from one I gave a few years ago (
http://people.apache.org/~trawick/AC2010-FastCGI.pdf).

(off the top of my head)

* definitely need to keep coverage of fcgid config challenges
* mod_proxy_fcgi needs detailed coverage (proxy config and best practices
for process management)
* implications of latest PHP FastCGI implementation
* deploying apps that are written to higher level programming interfaces
(e.g., WSGI) -- when/how to use FastCGI vs. other mechanisms (examples of
these higher level interfaces in different dynamic languages and some
deployment possibilities are covered at
http://people.apache.org/~trawick/AC2012EU-Apps.pdf)
* a couple of small tangents -- not much time, but just to provide exposure
** mod_authnz_fcgi - as motivation, provide an interesting example for
using this to move complex aaa out of httpd processes (yea!)
** mod_fastcgi - actually works with 2.4 but you need to know where to find
the big patch that handles most 2.4 stuff + a few smaller patches that
improve 2.4 compat and fix some other aggravations

I could easily see a broad coverage talk that goes no deeper than basic
configuration and one that covers proxy_fcgi and fcgid issues and
configuration in a fair amount of detail.  (herding cats?)



>
>
> Kean
>
>


-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message