httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Rumph <mike.ru...@oracle.com>
Subject Re: mod_remoteip
Date Mon, 09 Dec 2013 19:10:46 GMT
As you can see from the bug report, I have been looking into this.
It might also be important to  consider the related bug 55637:
- https://issues.apache.org/bugzilla/show_bug.cgi?id=55637

The setups so far have not included a RemoteIPProxiesHeader.
But if it is included, the mod_remote documentation seems to indicate 
that the value should be different from the RemoteIPHeader.
- 
http://httpd.apache.org/docs/trunk/mod/mod_remoteip.html#remoteipproxiesheader 


RemoteIPHeader  X-Forwarded-For
RemoteIPProxiesHeader  X-Forwarded-By

 From my analysis so far it appears that mod_remoteip is behaving as documented.
But the documentation is a little difficult to understand.

Thanks,

Mike Rumph


On 12/9/2013 10:52 AM, Reindl Harald wrote:
> Am 09.12.2013 19:28, schrieb Jim Jagielski:
>> This seems kinda serious....
>>
>> 	https://issues.apache.org/bugzilla/show_bug.cgi?id=55635
>>
>> any remoteip people able to look into this?
> i am willing to debug but i need a simplified
> step-to-step what to look for and how to
> reproduce if possible at all
>
> the mod_remoteip config looks like below
>
> RemoteIPHeader         X-Forwarded-For
> RemoteIPInternalProxy  <LAN-IP of own http://trafficserver.apache.org/>
> RemoteIPProxiesHeader  X-Forwarded-For
>


Mime
View raw message