httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: apache process ps -aux
Date Wed, 10 Jul 2013 19:16:10 GMT
On Wed, Jul 10, 2013 at 10:52 AM, peter_bateman <jrweisbrod@gmail.com>wrote:

> Hello All,
>
> I know this may be a newbie question,


Newbie or not, use the users@httpd mailing list for this sort of thing ;)



> however when i run the following
> command, all of my apache processes are listed with -k start. I have an
> example listed below:
>
> ps -aux | grep apache | grep -v grep
> apache   22397  3.5  0.3 360224 28476 ?        S    09:39   0:08
> /usr/sbin/httpd -k start
> apache   22559 10.3  0.4 365472 34572 ?        S    09:39   0:23
> /usr/sbin/httpd -k start
> apache   22721  4.9  0.3 363376 32588 ?        S    09:39   0:11
> /usr/sbin/httpd -k start
> apache   22723  5.2  0.3 363692 32112 ?        R    09:39   0:11
> /usr/sbin/httpd -k start
> apache   23059  6.0  0.3 361404 29824 ?        S    09:35   0:27
> /usr/sbin/httpd -k start
> apache   25198  4.4  0.3 361636 29752 ?        S    09:36   0:19
> /usr/sbin/httpd -k start
> apache   25396  5.1  0.3 360356 28736 ?        S    09:36   0:22
> /usr/sbin/httpd -k start
> apache   28921  8.1  0.3 359324 27904 ?        S    09:40   0:15
> /usr/sbin/httpd -k start
> apache   29474  4.6  0.3 359200 27708 ?        S    09:40   0:08
> /usr/sbin/httpd -k start
> apache   31748  5.0  0.3 362396 31272 ?        S    09:32   0:33
> /usr/sbin/httpd -k start
>
> I was wondering if anyone has any insight as to why the process is listing
> the -k start? I have never seen this on any of my other websevers,
> typcially
> they just show "0:33 /usr/sbin/httpd".
>

It was largely explained already.  There's a perhaps obvious bit that
didn't seem to be mentioned:  Both "/usr/sbin/httpd" and "/usr/sbin/httpd
-k start" are valid ways to start the server.  Different scripts could be
used in one environment vs. another or one start mechanism vs. another.


>
> I am running Centos 5.3, Server version: Apache/2.2.3
> Server built:   Jan 21 2009 22:00:55
>
> Any help would be appreciated :)
>
> Regards,
>
> peter_bateman
>
>
>
> --
> View this message in context:
> http://apache-http-server.18135.x6.nabble.com/apache-process-ps-aux-tp5007013.html
> Sent from the Apache HTTP Server - Dev mailing list archive at Nabble.com.
>



-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message