httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Gruno <rum...@cord.dk>
Subject Re: svn commit: r1466669 - /httpd/httpd/branches/2.4.x/STATUS
Date Fri, 12 Apr 2013 06:35:24 GMT
On 04/11/2013 11:24 PM, Gregg Smith wrote:
> On 4/11/2013 9:05 AM, Daniel Gruno wrote:
>> I just tried the script you attached on my Windows box, as well as the
>> original LuaRoot + LuaMapHandler problem, and I can't find anything
>> wrong with it, it works flawlessly with httpd 2.4.4 + mod_lua from trunk
>> (using Lua 5.1.4). There appears to be nothing in the code that triggers
>> it (go look yourself, I can't find anything), so I'm just about to chalk
>> it up to Windows (or possibly Lua for Windows) just acting weird for
>> some people.
>>
>> So, to sum up; I can't reproduce either of the crashes on my Windows 7
>> machine :(
> 
> Ok, so it's not Lua 5.1.5 or 5.2.2 as I just tried with 5.1.4 and
> trunk's mod_lua of r1466822
> I've ruled out the UAC in Vista, run from console vs. Windows Service.
> 
> So I'm curious, what did you build with (vc10/mingw/etc)?
> 
> Regards,
> 
> Gregg
I built it with VC11 in debug mode using Visual Studio Express 2012
(took a bloody long while to get it to build ;) ). I also tried the VC10
version from Apachelounge, and it too worked like a charm, so I'm
stumped as to what would/could cause the error you reported. If you have
some more info, or could try to reproduce it again with a backtrace, I'd
appreciate it, because I can't seem to find anything bad in the code -
the pool gets passed on as it should, so it shouldn't suddenly turn into
a null pointer at any point in the code :(.

With regards,
Daniel.

Mime
View raw message