httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Release Apache httpd 2.4.4 as GA - on AIX
Date Tue, 19 Feb 2013 11:57:09 GMT
so, it is intended that mod_crypto is not included with
--enable-mods-shared=all (and/or --enable-mpms-shared=all)?

If so, I shall add --with-crypto to the configure command in the build
script.

On Tue, Feb 19, 2013 at 10:01 AM, Graham Leggett <minfrin@sharp.fm> wrote:

> On 19 Feb 2013, at 10:12 AM, Michael Felt <mamfelt@gmail.com> wrote:
>
> Packaging went well, but still several compiler syntax warnings. Also, a
> configure warning - that I hope has no influence:
> configure: WARNING: Your APR does not include SSL/EVP support. To enable
> it: configure --with-crypto
> as I have --enable-ssl in the 2.2.24 configure while 2.4.X is using
> "merely"
>         --enable-mpms-shared=all
>         --enable-mods-shared=all
>         --disable-lua
>
>
> The --enable-ssl option in httpd enables mod_ssl, while the --with-crypto
> option to APR-util enables mod_session_crypto, which allows you to encrypt
> sessions.
>
> Regards,
> Graham
> --
>
>

Mime
View raw message