httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: Release Apache httpd 2.4.4 as GA - on AIX
Date Tue, 19 Feb 2013 12:06:02 GMT
On 19 Feb 2013, at 1:57 PM, Michael Felt <mamfelt@gmail.com> wrote:

> so, it is intended that mod_crypto is not included with --enable-mods-shared=all (and/or
--enable-mpms-shared=all)?

There is no such module as mod_crypto, rather a module called mod_session_crypto. This module
uses simple symmetrical encryption with a key to encrypt sessions. This module relies on an
abstraction library inside apr-util called the apr_crypto library, which gives you the ability
to encrypt and decrypt data.

To get support for this, you need to do the following:

- Ensure --with-crypto is passed to apr-util.
- Ensure that mod_session_crypto is compiled in.

Regards,
Graham
--


Mime
View raw message