httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <>
Subject Re: Building binaries and 3rd party dependencies
Date Wed, 06 Feb 2013 16:14:00 GMT
On Tue, 05 Feb 2013 16:43:13 -0800
Gregg Smith <> wrote:

> On 2/5/2013 2:12 PM, William A. Rowe Jr. wrote:
> > In catching up with building 2.2.23 and getting somewhere with 2.4.3
> > (soon to be .24 and .4 from today's email notes), I'm left with one
> > quandary.
> >
> > The 2.2 builds all used OpenSSL 0.9.8 and that's where I would leave
> > it, while 2.4 builds aught to use 1.0.1.  That, and libxml2 and lua
> > are the packages we don't bundle.
> Since chances are from responses previously posted here on the
> subject, any binary distribution coming from a.o is not going to be
> able to load mod_php (PHP 5.4's php5apache2_4.dll currently) so it
> forces the use of mod_fcgid. That being the case, I see no reason not
> to use openssl 1.0.1.

That may or may not be an issue.  On Windows we can load both the PHP
and mod_ssl flavors of OpenSSL at the same time if their dll names are
unique.  Unless msvc resources opened in httpd are closed by mod_php
or visa versa, two flavors of msvc can also coexist.  So mod_php aught
to load and function although mod_fcgid is still more optimal.

> > But for the expat and pcre dependencies, the versions we shipped in
> > 2.2.23 and 2.4.3-deps sources are falling out of date.  And I doubt
> > a bundle of 2.4.4-deps is going to be updated either.
> expat's still in APR, I know libxml2 can be used, not sure how to
> build with it though.

I plan to give libxml2 a spin in apr for httpd 2.4, given that
mod_proxy_html requires that lib anyways.

View raw message