httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: build error preventing build of AIX on 2.4.x
Date Tue, 25 Dec 2012 19:55:53 GMT
Rainer -- I have a similar AIX issue that I think may be up your
autoconf alley.

AFAICT, AIX bi-arch for open source is not so robust.  SSL for example ships as

/opt/freeware/lib/libssl.so
/opt/freeware/lib64/libssl.so
/opt/freeware/include/openssl/*.h

* pkg-config sets up -L for /opt/freeware/lib
* There is a pkg-config_64 that doesn't even know about the openssl-devel pkg.

Can you enhance acinclude.m4/configure.in/??? to allow e.g.

   --with-ssl-libs=/opt/freeware/lib64/

And combine it with the pkg-config output if it was found?

Thanks!

On Tue, Dec 25, 2012 at 2:32 PM, Eric Covener <covener@gmail.com> wrote:
> On Sun, Dec 23, 2012 at 11:59 AM, Michael Felt <mamfelt@gmail.com> wrote:
>> Seems I was naughty - and had forgot that I needed to do a new buildconf
>> after a svn get.
>>
>> Not sure about a warning message to add --with-crypto to the configure
>> command.
>>
>> And, Merry Christmas!
>>
>>
>
> Does 64-bit work for you w/ SSL?  I'm on a rebuilt build system, and
> have problems w/ perzl.org openssl under 64-bit.
>
> My system is also very slow, so every permutation and build tweak
> takes forever to give any feedback.



--
Eric Covener
covener@gmail.com

Mime
View raw message