httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zisis Lianas <Zisis.Lia...@consol.de>
Subject Re: Bug with "ProxyPass /" and mod_proxy_balancer + double-slashes (httpd-2.4.3)
Date Thu, 13 Sep 2012 18:06:47 GMT
With this configuration I get a 500 error because of
"[proxy_balancer:trace1] ... mod_proxy_balancer.c(73): ... canonicalising
URL //defaultclusterjsp", when trying to access "/clusterjsp":
  ProxyPass / balancer://default
  ProxyPassReverse / balancer://default
Maybe this also expected.


But:
With this configuration I get the doubleslash bug, when the
backend is returning a 301:
  ProxyPass / balancer://default/
  ProxyPassReverse / balancer://default/

See also "proxypass_20120906.0.txt" attachment in one of my
emails before with the logfile trace.


----- Original Message -----
From: "Jim Jagielski" <jim@jaguNET.com>
To: dev@httpd.apache.org
Sent: Thursday, September 13, 2012 6:54:36 PM
Subject: Re: Bug with "ProxyPass /" and mod_proxy_balancer + double-slashes (httpd-2.4.3)


On Sep 6, 2012, at 11:07 AM, Zisis Lianas <Zisis.Lianas@consol.de> wrote:

> Tom, thanks for your feedback.
> 
> The main difference between our configurations is that you do
> ProxyPassReverse the single BalancerMember (http://app05/...),
> which is also working for me - in my configuration I ProxyPassReverse
> the "balancer://cluster". And this is the configuration which does
> not work correctly.
> 
> So...
> ProxyPassReverse / http://app05/ => WORKS
> ProxyPassReverse / balancer://cluster/ => DOES NOT WORK CORRECTLY
> 
> As documented the balancer://... ProxyPassReverse should work:
> http://httpd.apache.org/docs/2.4/mod/mod_proxy_balancer.html#example
> 
> 

How is it not working for you?


Mime
View raw message