httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: mod_spnego with Apache 2.4.2
Date Sat, 04 Aug 2012 11:53:32 GMT
On Fri, Aug 3, 2012 at 10:03 PM, Rai, Pravesh R (STSD)
<pravesh.rai@hp.com> wrote:
> Hi,
>
>
>
> While trying to compile mod_spnego (0.1.0 / 0.2.0) with Apache 2.4.2 (using
> Visual Studio 2005), have got following error:
>
>
>
> mod_spnego.obj : error LNK2001: unresolved external symbol _ap_requires
>
>
>
> After going through httpd modules, realized that 'ap_requires()' function is
> no more supported in Apache 2.4.2.
>
>
>
> Can anybody please help me out?

It needs to register an auth provider.  As a simple example, compare
the 2.2 and 2.4 versions of the bundled module mod_authz_dbm.c.

> Thanks & Regards,
>
> Pravesh



-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message