httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@links.org>
Subject Re: Linking mod_ssl with a specific OpenSSL version
Date Thu, 09 Aug 2012 10:25:43 GMT
On Thu, Aug 9, 2012 at 9:42 AM, Joe Orton <jorton@redhat.com> wrote:
> On Thu, Aug 09, 2012 at 04:56:03AM +0100, Ben Laurie wrote:
>> On Wed, Aug 8, 2012 at 5:03 PM, Joe Orton <jorton@redhat.com> wrote:
>> > This all seems totally crazy to me.  Why are we adding complexity to the
>> > httpd build system so openssl devs can skip typing the " install" part
>> > of running "make install" when testing against modified versions of
>> > OpenSSL?  Joe
>>
>> IIRC, the issue is that it doesn't build correctly even if you do that
>> (to a non-standard location - and clearly installing to a standard
>> location is nuts).
>
> Doesn't build correctly... in what way?  I've done that loads of times
> building against OpenSSL from CVS.  All the code is still there so it
> better work or else we need to see bug reports.

In that it uses (parts of) the default install instead of the install
you specify. At least for some versions. I forget the details coz I
fixed it...

>
> Regards, Joe

Mime
View raw message