httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Browder <tom.brow...@gmail.com>
Subject Errors Building Docs from Trunk (Apparently Solved)
Date Thu, 05 Jul 2012 20:48:43 GMT
I'm trying to build the docs from the trunk following instructions here:

  http://httpd.apache.org/docs-project/docsformat.html

(Note the first heading on the page is "Module Format and
Transformation" which I believe would better read "Document Format and
Transformation" or something similar.)

I tried the target:

  $ ./build.sh latex-en

and got these errors:

latex-en:
     [xslt] Processing
/usr/local/src/apache-trunk-svn/docs/manual/misc/perf-scaling.xml to
/usr/local/src/apache-trunk-svn/docs/manual/misc/perf-scaling.tex
     [xslt] Loading stylesheet
/usr/local/src/apache-trunk-svn/docs/manual/style/latex/latex.xsl
     [xslt] : Fatal Error! org.xml.sax.SAXException: Attempt to output
character of integral value 8220 that is not represented in specified
output encoding of ISO-8859-1. Cause: org.xml.sax.SAXException:
Attempt to output character of integral value 8220 that is not
represented in specified output encoding of ISO-8859-1.
     [xslt] Failed to process
/usr/local/src/apache-trunk-svn/docs/manual/misc/perf-scaling.xml

BUILD FAILED
/usr/local/src/apache-trunk-svn/docs/manual/style/lang-targets.xml:106:
The following error occurred while executing this line:
/usr/local/src/apache-trunk-svn/docs/manual/build/build.xml:805: The
following error occurred while executing this line:
/usr/local/src/apache-trunk-svn/docs/manual/build/build.xml:820: Fatal
error during transformation

I looked at file "docs/manual/style/latex/latex.xsl" and noticed this
code chunk:

<xsl:output
  method="text"
  encoding="ISO-8859-1"
  indent="no"
/>

I also noticed other style sheets with the same chunk.  Is there any
reason not to use 'encoding="utf-8"' instead of "ISO-8859-1" in all
such chunks?

If that is correct and intended, can anyone help with that error?

In the meantime I changed all the xsl files with the ISO encoding and
changed them to "utf-8" and got an apparent good build.  However,
there are still charsets and other encoding references to ISO-8858-1,
so someone knowledgeable of the doc direction needs to comment.

Thanks.

Best regards,

-Tom

Mime
View raw message