httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Locke <ke...@kevinlocke.name>
Subject qs values for MultiViews sent in Content-Type
Date Fri, 20 Jul 2012 17:57:41 GMT
Hello All,

It appears that the qs values specified on media types for use by
MultiViews during content negotiation are being sent to clients in the
Content-Type header field.  This problem was originally brought up in
2002 on httpd-users[1] and http-dev[2], and it was also discussed on
ietf-http-wg[3] and in other venues subsequently.  The consensus
appears to be that it is a bug, that it probably has low impact, and
that it may be difficult to fix.

I have just confirmed that the bug still appears in 2.4.2 and I'd like
to get opinions on the following:

- Is there still agreement that this is a bug?
- Are there any known workarounds?
- Is there any objection to me filing a bug report to track progress
  on the issue?

I recognize that this bug is not likely to be a priority, but a bug
report (and/or updates to the docs) might help others to be aware of
the problem and avoid wasting time trying to diagnose and workaround
the behavior.

I welcome your thoughts.

Thanks,
Kevin

1.  http://mail-archives.apache.org/mod_mbox/httpd-users/200202.mbox/%3CELEDJONBOPPAEGANDEEIKEEKCBAA.joshua@slive.ca%3E
2.  http://mail-archives.apache.org/mod_mbox/httpd-dev/200202.mbox/%3C0adf01c1b994$645169c0$94c0b0d0@v505%3E
3.  http://lists.w3.org/Archives/Public/ietf-http-wg/2002AprJun/0032.html

-- 
Cheers,      |  kevin@kevinlocke.name   | JIM:  kevinoid@jabber.org
Kevin        |  http://kevinlocke.name  | IRC: kevinoid on freenode

Mime
View raw message