httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henrik Strand <henrik.str...@axis.com>
Subject Re: [PATCH Attachment 28632, Bug 51257] Build failed when cross-compiling: ./gen_test_char: cannot execute binary file
Date Fri, 20 Apr 2012 12:59:03 GMT
Hi Guenter,

I've applied and tried the modified patch
(http://svn.apache.org/viewvc?view=revision&revision=1327907) but it
seems that the BUILD_FOR_CC value isn't propagated to the Makefile in
the server folder.

Did it work for you? If so, what more did you have to do in order to get
it to work?

Kind Regards,
Henrik

On Thu, 2012-04-19 at 13:25 +0200, Guenter Knauf wrote:
> Hi Henrik,
> Am 19.04.2012 10:39, schrieb Henrik Strand:
> > I based the patch on the old 2003 patch
> > (http://marc.info/?l=apache-httpd-dev&m=106150997309208&w=2) that you
> > said looked harmless.
> >
> > Anyhow, exactly how do you want it to be solved? Since I have not worked
> > with configure scripts before all help is appreciated
> I've now spent 2 hours with trying to figure out from where all vars 
> come ..., and its configure hell :-)
> I admit that my knowledge about configure is also really limited ...
> I'm just trying to do something link that:
> export CC_FOR_BUILD=gcc
> and then test for this in the makefiles; its my hope that we might get 
> CC_FOR_BUILD finally automatically populated by configure ...
> so I'd say lets use CC_FOR_BUILD so that once we've figured out how to 
> teach configure to set this var we dont need to change the makefiles 
> again ...
> I'm currently trying with 2.2.22 (sure the patch has finally to go into 
> trunk 1st) because thats ATM easier for my cross-compile testing 
> (apr/apu/pcre included)
> If it works what I'm testing I will attach an updated patch to your bug.
> 
> greets, Gün.
> 
> 



Mime
View raw message