httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Cannot start httpd v2.4.1 with mpm_build on AIX
Date Tue, 27 Mar 2012 07:07:26 GMT
since my packaging scripts are not part of apr or apr-util I believe the
following change is warrented:

--- httpd-2.4.x/build/aix/buildaix.ksh  (revision 1305578)
+++ httpd-2.4.x/build/aix/buildaix.ksh  (working copy)
@@ -62,14 +62,12 @@

 if [ ! -f "$apr_config" -a ! -f "$apr_config/configure.in" ]; then
   echo "The apr source directory / apr-1-config could not be found"
-  echo "If available, install the ASF.apu.rte and ASF.apr.rte filesets"
   echo "Usage: $cmd [--with-apr=[dir|file]] [--with-apr-util=[dir|file]]"
   exit 1
 fi

 if [ ! -f "$apu_config" -a ! -f "$apu_config/configure.in" ]; then
   echo "The apu source directory / apu-1-config could not be found"
-  echo "If available, install the ASF.apu.rte and ASF.apr.rte filesets"
   echo "Usage: $cmd [--with-apr=[dir|file]] [--with-apr-util=[dir|file]]"
   exit 1
 fi


Also, the file "aixproto.ksh" needs to be removed. It was renamed/has been
replaced by mkinstallp.ksh.

On Tue, Mar 27, 2012 at 1:47 AM, Guenter Knauf <fuankg@apache.org> wrote:

> Hi Michael,
> Am 26.03.2012 23:50, schrieb Michael Felt:
>
>  Installation Summary
>> --------------------
>> Name                        Level           Part        Event       Result
>> ------------------------------**------------------------------**
>> -------------------
>> ASF.httpd.rte               2.4.2.0         USR         APPLY
>> SUCCESS
>> ASF.httpd.rte               2.4.2.0         ROOT        APPLY
>> SUCCESS
>> root@x103:[/data/prj/httpd-2.**4.x]
>>
>> root@x103:[/data/prj/httpd-2.**4.x]/opt/httpd/sbin/apachectl -t
>> Syntax OK
>> root@x103:[/data/prj/httpd-2.**4.x]
>>
> thanks very much for testing and confirming that it works!
>
> greets, Gün.
>
>
>

Mime
View raw message