httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Cannot start httpd v2.4.1 with mpm_build on AIX
Date Thu, 29 Mar 2012 21:55:55 GMT
The patched 2.4.2 version passes the syntax test:
Installation Summary
--------------------
Name                        Level           Part        Event       Result
-------------------------------------------------------------------------------
ASF.httpd.rte               2.4.2.0         USR         APPLY
SUCCESS
ASF.httpd.rte               2.4.2.0         ROOT        APPLY
SUCCESS
root@x103:[/data/prj/httpd-2.4.x]lslpp -L | grep ASF
  ASF.apr.rte                1.5.0.0    C     F    apr version 1.5.0 for
powerpc
  ASF.apu.rte                1.5.0.0    C     F    apu version 1.5.0 for
powerpc
  ASF.httpd.rte              2.4.2.0    C     F    httpd version 2.4.2 for
root@x103:[/data/prj/httpd-2.4.x]/opt/httpd/sbin/apachectl -t
Syntax OK
root@x103:[/data/prj/httpd-2.4.x]

The httpd-2.5.x also passes (used vac.11, and AIX 6.1)

Installation Summary
--------------------
Name                        Level           Part        Event       Result
-------------------------------------------------------------------------------
ASF.httpd.rte               2.5.0.0         USR         APPLY
SUCCESS
ASF.httpd.rte               2.5.0.0         ROOT        APPLY
SUCCESS
root@x104:[/data/prj/httpd-2.5.x]/opt/httpd/sbin/apachectl -t
AH00544: httpd: bad group name daemon
root@x104:[/data/prj/httpd-2.5.x]mkgroup daemon
root@x104:[/data/prj/httpd-2.5.x]/opt/httpd/sbin/apachectl -t
Syntax OK
root@x104:[/data/prj/httpd-2.5.x]lslpp -L | grep ASF
  ASF.apr.rte                1.5.0.0    C     F    apr version 1.5.0 for
powerpc
  ASF.apu.rte                1.5.0.0    C     F    apu version 1.5.0 for
powerpc
  ASF.httpd.rte              2.5.0.0    C     F    httpd version 2.5.0 for
root@x104:[/data/prj/httpd-2.5.x]

On Wed, Mar 28, 2012 at 3:41 PM, Guenter Knauf <fuankg@apache.org> wrote:

> Hi Michael,
> Am 27.03.2012 09:07, schrieb Michael Felt:
>
>> since my packaging scripts are not part of apr or apr-util I believe the
>> following change is warrented:
>>
>> --- httpd-2.4.x/build/aix/**buildaix.ksh  (revision 1305578)
>> +++ httpd-2.4.x/build/aix/**buildaix.ksh  (working copy)
>> @@ -62,14 +62,12 @@
>>
>>  if [ ! -f "$apr_config" -a ! -f "$apr_config/configure.in
>> <http://configure.in>" ]; then
>>
>>    echo "The apr source directory / apr-1-config could not be found"
>> -  echo "If available, install the ASF.apu.rte and ASF.apr.rte filesets"
>>    echo "Usage: $cmd [--with-apr=[dir|file]] [--with-apr-util=[dir|file]]"
>>    exit 1
>>  fi
>>
>>  if [ ! -f "$apu_config" -a ! -f "$apu_config/configure.in
>> <http://configure.in>" ]; then
>>
>>    echo "The apu source directory / apu-1-config could not be found"
>> -  echo "If available, install the ASF.apu.rte and ASF.apr.rte filesets"
>>    echo "Usage: $cmd [--with-apr=[dir|file]] [--with-apr-util=[dir|file]]"
>>    exit 1
>>  fi
>>
> I'd say let these hints in, and lets look forward that your build scripts
> will make it finally into APR/APU too;
> perhaps also do a checkout of APR/APU 1.5.x and post (again?) a patch for
> this branch to the apr-dev list.
>
>
>  Also, the file "aixproto.ksh" needs to be removed. It was renamed/has
>> been replaced by mkinstallp.ksh.
>>
> since I have no knowledge about this I leave that for someone familar with
> AIX; Graham perhaps?
>
> Gün.
>
>
>

Mime
View raw message