httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: Announcement 2.4.1
Date Thu, 08 Mar 2012 20:27:25 GMT
On 3/8/2012 6:29 AM, Steffen wrote:
> I am not aware of current versions of the dependencies that have issues:  apr-1.4.6-P1
> apr-util-1.4.1 apr-iconv-1.2.1 pcre-8.21 lua-5.1 libxml2-2.7.8 openssl-1.0.0g zlib-1.2.6.
> In fact, it works like a charm.

Nor am I (aware of issues), however expat 2.0.1 has vulnerabilites which
are corrected in the expat project's svn but not in a 'release' (we have
a patched flavor of 1.9.5 in apr project's repository).  We won't ship the
apr 1.4.6 +patch, but would wait for apr to release again.  OpenSSL is
about to deliver 1.0.1 (and then deprecate 1.0.0 long before we finish any
httpd 2.4 cycle) so waiting the additional week or few for the brand new
openssl 1.0.1 and a new apr tag (and a new expat 2.0.2 would really be
lovely).

Mario is correct, it not difficult to derive windows sources and convert
the .dsp to .vcproj files as needed.  I hadn't worked out yet the right
approach to the windows .mak files, what with the separation of httpd and
its dependencies.  Let me spend my weekend messing with the details.

Mime
View raw message