httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Cannot start httpd v2.4.1 with mpm_build on AIX
Date Sun, 26 Feb 2012 21:32:58 GMT
I am quite sure. Just ran a build with --with-mpm=worker and that works
fine as well.

Currently building again with:
        ./configure \
                --enable-layout=$LAYOUT \
                --with-apr=$apr_config \
                --with-apr-util=$apu_config \
                --enable-mpms-shared=all \
                --enable-mods-shared=all \
                --disable-lua > build/aix/configure.out

Just to be sure the error is repeatable. :)

On Sun, Feb 26, 2012 at 10:09 PM, Graham Leggett <minfrin@sharp.fm> wrote:

> On 26 Feb 2012, at 10:30 PM, Michael Felt wrote:
>
> > Unfortunately, although it builds fine, it does not start:
> >
> > httpd: Syntax error on line 143 of /etc/httpd/httpd.conf: Cannot load
> /opt/httpd/libexec/mod_mpm_worker.so into server: rtld: 0712-001 Symbol
> ap_fatal_signal_setup was referenced\n      from module
> /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime definition\n      of
> the symbol was not found.\nrtld: 0712-001 Symbol ap_pid_fname was
> referenced\n      from module /opt/httpd/libexec/mod_mpm_worker.so(), but a
> runtime definition\n      of the symbol was not found.\nrtld: 0712-001
> Symbol ap_reclaim_child_processes was referenced\n      from module
> /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime definition\n      of
> the symbol was not found.\nrtld: 0712-001 Symbol ap_relieve_child_processes
> was referenced\n      from module /opt/httpd/libexec/mod_mpm_worker.so(),
> but a runtime definition\n      of the symbol was not found.\nrtld:
> 0712-001 Symbol ap_graceful_shutdown_timeout was referenced\n      from
> module /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime definition\n
>    of the symbol was not found.\nrtld: 0712-001 Symbol ap_mpm_safe_kill was
> referenced\n      from module /opt/httpd/libexec/mod_mpm_worker.so(), but a
> runtime definition\n      of the symbol was not found.\nrtld: 0712-001
> Symbol ap_wait_or_timeout was referenced\n      from module
> /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime definition\n      of
> the symbol was not found.\n\t0509-021 Additional errors occurred but are
> not reported.
> >
> > I have been able to find a few of these routines in source code, e,g,
> server/mpm_unix.c, but the routines are not included in
> server/mpm_worker.o, hence ....
>
> Are you 100% sure your system doesn't have a mix of competing binaries? In
> other words, just one copy of httpd, and just one copy of the httpd modules?
>
> Also, you're trying to load just one MPM, and not all of them?
>
> Regards,
> Graham
> --
>
>

Mime
View raw message