httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject Re: Cannot start httpd v2.4.1 with mpm_build on AIX
Date Sun, 26 Feb 2012 22:09:02 GMT
patched manually, building...

On Sun, Feb 26, 2012 at 10:56 PM, Michael Felt <mamfelt@gmail.com> wrote:

> er, almost working:
> michael@x054:[/data/prj/httpd-2.4.1]patch -p0 -i *.patch
> Processing...  Looks like a unified context diff...
> The text leading up to this was:
> --------------------------
> |Index: include/mpm_common.h
> |===================================================================
> |--- include/mpm_common.h       (revision 1293841)
> |+++ include/mpm_common.h       (working copy)
> --------------------------
> Patching file include/mpm_common.h using Plan A...
> patch: 3016-037 Malformed patch at line 9: -void
> ap_reclaim_child_processes(int terminate,
>
>
>
> On Sun, Feb 26, 2012 at 10:53 PM, Michael Felt <mamfelt@gmail.com> wrote:
>
>> :) patch from AIX 6.1 works, starting build.
>>
>>
>> On Sun, Feb 26, 2012 at 10:52 PM, Michael Felt <mamfelt@gmail.com> wrote:
>>
>>> re: not exported... They are not in the .o files either (or is that
>>> because they are not exported?)
>>>
>>>
>>> On Sun, Feb 26, 2012 at 10:51 PM, Michael Felt <mamfelt@gmail.com>wrote:
>>>
>>>> I am not so smart I fear, and still no svm installed (working on
>>>> building gnudiff, but not done yet...
>>>>
>>>> root@x105:[/data/prj/httpd-2.4.1]patch -i *patch
>>>> Processing...  I cannot find a patch in there anywhere.
>>>>
>>>>
>>>>
>>>> On Sun, Feb 26, 2012 at 10:44 PM, Jeff Trawick <trawick@gmail.com>wrote:
>>>>
>>>>> On Sun, Feb 26, 2012 at 3:30 PM, Michael Felt <mamfelt@gmail.com>
>>>>> wrote:
>>>>> > Unfortunately, although it builds fine, it does not start:
>>>>> >
>>>>> > httpd: Syntax error on line 143 of /etc/httpd/httpd.conf: Cannot
load
>>>>> > /opt/httpd/libexec/mod_mpm_worker.so into server: rtld: 0712-001
>>>>> Symbol
>>>>> > ap_fatal_signal_setup was referenced\n      from module
>>>>> > /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime
>>>>> definition\n      of
>>>>> > the symbol was not found.\nrtld: 0712-001 Symbol ap_pid_fname was
>>>>> > referenced\n      from module
>>>>> /opt/httpd/libexec/mod_mpm_worker.so(), but a
>>>>> > runtime definition\n      of the symbol was not found.\nrtld:
>>>>> 0712-001
>>>>> > Symbol ap_reclaim_child_processes was referenced\n      from module
>>>>> > /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime
>>>>> definition\n      of
>>>>> > the symbol was not found.\nrtld: 0712-001 Symbol
>>>>> ap_relieve_child_processes
>>>>> > was referenced\n      from module
>>>>> /opt/httpd/libexec/mod_mpm_worker.so(),
>>>>> > but a runtime definition\n      of the symbol was not found.\nrtld:
>>>>> 0712-001
>>>>> > Symbol ap_graceful_shutdown_timeout was referenced\n      from module
>>>>> > /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime
>>>>> definition\n      of
>>>>> > the symbol was not found.\nrtld: 0712-001 Symbol ap_mpm_safe_kill
was
>>>>> > referenced\n      from module
>>>>> /opt/httpd/libexec/mod_mpm_worker.so(), but a
>>>>> > runtime definition\n      of the symbol was not found.\nrtld:
>>>>> 0712-001
>>>>> > Symbol ap_wait_or_timeout was referenced\n      from module
>>>>> > /opt/httpd/libexec/mod_mpm_worker.so(), but a runtime
>>>>> definition\n      of
>>>>> > the symbol was not found.\n\t0509-021 Additional errors occurred
but
>>>>> are not
>>>>> > reported.
>>>>> >
>>>>> > I have been able to find a few of these routines in source code,
e,g,
>>>>> > server/mpm_unix.c, but the routines are not included in
>>>>> server/mpm_worker.o,
>>>>> > hence ....
>>>>> >
>>>>> > Suggestions welcome (other than filing a bug report).
>>>>>
>>>>> I guess the problem is that those MPM APIs are not decorated with
>>>>> AP_DECLARE() so they don't get added to httpd.exp so they don't get
>>>>> exported from httpd on AIX.
>>>>>
>>>>> Can you try the attached patch to mpm_common.h?
>>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message