httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregg Smith <...@gknw.net>
Subject Re: Intent to T&R 2.4.1
Date Mon, 13 Feb 2012 03:55:12 GMT
On 2/12/2012 11:30 AM, Mladen Turk wrote:
> On 02/12/2012 04:57 PM, Mario Brandt wrote:
>> Bug 52402[1] isn't working yet. I wonder why it is marked as fixed in
>> 2.4.x CHANGES[2] The shared memory stuff doesn't work yet on windows.

PR 52402 works for me, not with the configuration in the PR, but these 
errors are gone

[Fri Dec 30 20:55:43.004798 2011] [proxy_balancer:emerg] [pid 3632:tid 428]
(22)Invalid argument: AH01186: worker slotmem_grab failed
AH00020: Configuration Failed

As long as I point BalancerMember to other machines, it works just fine

>> Odd Behavior:
>>
>> 1. If mod_auth_digest is loaded and on Windows Vista/2008/7 do not try
>> to start from console, it will not start.
>>
>
> It works for me (winows7 32-bit)
>
>> 2. If mod_heartmonitor is loaded and using mod_slotmem_shm and on
>> Windows Vista/2008/7 do not try to start from console, it will not
>> start.
>>
>
> Again, it works for me, without a hitch.

These last two work fine for me if I am running the console as 
Administrator, or running as a service under any user.

>
> Note that I have used VC 6.0 + Server 2003R2 PSDK and
> build directly from .dsw/.dsp files.
> Also I used pcre sources from old httpd (the cmake build just sucks
> and I cannot make that working on windoze).
>

These are VC9 builds here w/ latest PCRE since VC6 is as good as dead. 
There's even been mention to do away with the .dsw/.dsp files which I am 
strongly against for reason other than supporting VC6. This  just may 
have something to do with the newer msvcrt.

>
> Since both digest and slotem use shared memory I presume that
> either its something broken with your compiler or your box.
>
>
> Regards

Cheers

Mime
View raw message