httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From csross <cr...@hccs.com>
Subject Re: which apr to use, version numbering confusion
Date Mon, 27 Feb 2012 21:51:10 GMT

Hi,

It was suggested that I try and use apr 1.3.9 and apu 1.3.9 to try and stop
the problem with graceful restarts and processes being stuck in "G" state if
you have more than 1 listener (ie) port 80 and port 443.  I have been trying
the newer versions of apache and I still have that problem with 2.2.22
(compile on solaris with gcc).  The only way to clear them is to restart
apache.

Can I download apr and apr-util 1.3.9, and specify to use both apr and
apr-util on the ./configure line?  

Do you know if there are any plans to fix this issue?

thanks



Ruediger Pluem wrote:
> 
> 
> 
> Mikhail T. wrote:
>> On 27.12.2011 08:24, Ruediger Pluem wrote:
>>> Some modules in 2.3 require the apr-util crypto API. These
>>> won't work with older apr-util versions.
>> Oh, Ok -- so a module may just not be built, if apr(-util) is too old at
>> compile time. But if it is available, it is
>> fully-featured, right? In other words, there are no silent #ifs in the
>> code like:
>> 
>>     #if APR_UTIL_VERSION < 1.4
>>     disable some really cool feature or performance improvement
>>     #endif
> 
> Not directly, but you need to have apr-util 1.4 available during compile
> time to get these modules compiled.
> 
> Regards
> 
> RĂ¼diger
> 
> 

-- 
View this message in context: http://old.nabble.com/which-apr-to-use%2C-version-numbering-confusion-tp33039336p33402972.html
Sent from the Apache HTTP Server - Dev mailing list archive at Nabble.com.


Mime
View raw message