httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steffen" <>
Subject Re: [VOTE] Release Apache httpd 2.4.1
Date Wed, 15 Feb 2012 17:47:39 GMT
Looks my experience. The mentioned causes, I do not know.  With mentioning
an announcement you are suggesting that it is going to be GA with this very
serious bug.

When the bug is not solved, ASF leaves quite some Windows users in the dark.
But thats's an ASF decission. Do not expect that ASF get lot of reports,
because the bug is already discussed here and AL. And most does not even try

Accept filter none/connect:
In 2.2 with DisableWin32AcceptEx all fine.
Why oh why not reverting to that behaviour, is it principal ?
In the httpd sources there a many *nix and Win if-statements,
why not: if Win then pick up the 2.2 code  instead of new https none,
looks to me a good compromise for the time being.
And that timing  is the cause looks to me a guess.

Blaming (stack) drivers with set to data:
Bug shows when tested with server rated cards from Broadcom and Intel with
old and new certified drivers on clean 2008 R2 and SP1 and XP and with
consumer rated cards like Realtek, and that on quite some different boxes.
So feels bug is not there, but you are the expert.


-----Original Message----- 
From: William A. Rowe Jr.
Sent: Wednesday, February 15, 2012 5:04 PM
Subject: Re: [VOTE] Release Apache httpd 2.4.1

On 2/15/2012 8:12 AM, Steffen wrote:
> Forget to be clear that SSL is still broken.
> Expect that 2.4.1 is not got released as GA.

And to be more clear for any potential announcement;

1. AcceptFilter data [default] + mod_ssl works
    (except when it doesn't - those users who previously had to use
      for one socket stack driver bug or another)

2. AcceptFilter none/connect + mod_ssl exhibits timing sensitive retry
    problems which cause mod_ssl connections to intermittently fail.
    (How intermittent is a timing side effect of browser and server).

Is that your understanding of the present bug?

> Btw, build with IPv6 apr-1.4.6 apr-util-1.4.1 apr-iconv-1.2.1 pcre-8.21
> lua-5.1
> libxml2-2.7.8 openssl-1.0.0g zlib-1.2.6

Thanks for precise details! 

View raw message